# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((ftp|http|https):\/\/)?(www.)?(?!.*(ftp|http|https|www.))[a-zA-Z0-9_-]+(\.[a-zA-Z]+)+((\/)[\w#]+)*(\/\w+\?[a-zA-Z0-9_]+=\w+(&[a-zA-Z0-9_]+=\w+)*)?$"
test_str = ("http://www.sample.com\n"
"https://www.sample.com\n"
"http://www.sample.com/xyz\n"
"www.sample.com\n"
"www.sample.com/xyz/#/xyz\n"
"sample.com\n"
"www.sample.com\n"
"mofiz.com\n"
"kolim.com\n"
"www.murikhao.www.sample.com\n"
"http://murihao.www.sample.com\n"
"http://www.sample.com/xyz?abc=dkd&p=q&c=2\n"
"www.sample.gov.bd\n"
"www.sample.com.en\n"
"www.sample.vu\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.