using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<SHA>[0-9a-f]+)\s+\(\S+\s+\d{4}-\d{2}-\d{2}\ \d{2}:\d{2}:\d{2}\ [+-]\d{4}\s+(?<line>\d+)\)\ ?(?<code>.*)$";
string input = @"f02d38023450 (PersonA 2019-08-03 13:27:04 +0200 2338) <whitespace>
a7ebc6f94ab4 (PersonB 2019-11-04 12:05:07 +0100 2339) <some code>
a7ebc6f94ab4 (PersonA 2019-11-04 12:05:07 +0100 2340) <some code>
f02d38023450 (PersonA 2019-08-03 13:27:04 +0200 2341) <whitespace>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}