import re
regex = re.compile(r"^(?<SHA>[0-9a-f]+)\s+\(\S+\s+\d{4}-\d{2}-\d{2}\ \d{2}:\d{2}:\d{2}\ [+-]\d{4}\s+(?<line>\d+)\)\ ?(?<code>.*)$", flags=re.MULTILINE)
test_str = ("f02d38023450 (PersonA 2019-08-03 13:27:04 +0200 2338) <whitespace>\n"
"a7ebc6f94ab4 (PersonB 2019-11-04 12:05:07 +0100 2339) <some code>\n"
"a7ebc6f94ab4 (PersonA 2019-11-04 12:05:07 +0100 2340) <some code> \n"
"f02d38023450 (PersonA 2019-08-03 13:27:04 +0200 2341) <whitespace>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")