const regex = /^(?<SHA>[0-9a-f]+)\s+\(\S+\s+\d{4}-\d{2}-\d{2}\ \d{2}:\d{2}:\d{2}\ [+-]\d{4}\s+(?<line>\d+)\)\ ?(?<code>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<SHA>[0-9a-f]+)\\s+\\(\\S+\\s+\\d{4}-\\d{2}-\\d{2}\\ \\d{2}:\\d{2}:\\d{2}\\ [+-]\\d{4}\\s+(?<line>\\d+)\\)\\ ?(?<code>.*)$', 'gm')
const str = `f02d38023450 (PersonA 2019-08-03 13:27:04 +0200 2338) <whitespace>
a7ebc6f94ab4 (PersonB 2019-11-04 12:05:07 +0100 2339) <some code>
a7ebc6f94ab4 (PersonA 2019-11-04 12:05:07 +0100 2340) <some code>
f02d38023450 (PersonA 2019-08-03 13:27:04 +0200 2341) <whitespace>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}