#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b"
Local $sString = "Visa" & @CRLF & _
"" & @CRLF & _
"Requirements: Visa numbers start with the number 4 and have either 13, 16, or 19 digits (new cards)." & @CRLF & _
"" & @CRLF & _
"Pattern Parts:" & @CRLF & _
"Starts with number 4 and 13 length:" & @CRLF & _
"1) \b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b" & @CRLF & _
"" & @CRLF & _
"Starts with number 4 and 16 length:" & @CRLF & _
"2) \b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b" & @CRLF & _
"" & @CRLF & _
"Starts with number 4 and 19 length:" & @CRLF & _
"3) \b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b" & @CRLF & _
"" & @CRLF & _
"Combining 1-3 to form one pattern:" & @CRLF & _
"\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Test Cases:" & @CRLF & _
"Positive (should fire):" & @CRLF & _
"13 length, no space, start with 4 Here is the cc: 4123123412341 Thanks." & @CRLF & _
"13 length, dashes, start with 4 4123-1234-1234-1" & @CRLF & _
"13 length, spaces, start with 4 4123 1234 1234 1" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 4 4221123412341234" & @CRLF & _
"16 length, dashes, start with 4 4221-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 4 4221 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"19 length, no space, start with 4 4241123412341234123" & @CRLF & _
"19 length, dashes, start with 4 4241-1234-1234-1234-123" & @CRLF & _
"19 length, spaces, start with 4 4241 1234 1234 1234-123" & @CRLF & _
"" & @CRLF & _
"Embedded in sentence with space:" & @CRLF & _
"13 length, no space, start with 4 Here is the cc: 4123123412341" & @CRLF & _
"13 length, dashes, start with 4 Here is the cc: 4123-1234-1234-1" & @CRLF & _
"13 length, spaces, start with 4 Here is the cc: 4123 1234 1234 1" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 4 Here is the cc: 4221123412341234" & @CRLF & _
"16 length, dashes, start with 4 Here is the cc: 4221-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 4 Here is the cc: 4221 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"19 length, no space, start with 4 Here is the cc: 4241123412341234123" & @CRLF & _
"19 length, dashes, start with 4 Here is the cc: 4241-1234-1234-1234-123" & @CRLF & _
"19 length, spaces, start with 4 Here is the cc: 4241 1234 1234 1234-123" & @CRLF & _
"" & @CRLF & _
"13 length, no space, start with 4 Here is the card#:4123123412341" & @CRLF & _
"13 length, dashes, start with 4 Here is the card#:4123-1234-1234-1" & @CRLF & _
"13 length, spaces, start with 4 Here is the card#:4123 1234 1234 1" & @CRLF & _
"" & @CRLF & _
"16 length, no space, start with 4 Here is the card#:4221123412341234" & @CRLF & _
"16 length, dashes, start with 4 Here is the card#:4221-1234-1234-1234" & @CRLF & _
"16 length, spaces, start with 4 Here is the card#:4221 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"19 length, no space, start with 4 Here is the card#:4241123412341234123" & @CRLF & _
"19 length, dashes, start with 4 Here is the card#:4241-1234-1234-1234-123" & @CRLF & _
"19 length, spaces, start with 4 Here is the card#:4241 1234 1234 1234-123" & @CRLF & _
"" & @CRLF & _
"Negative (should not fire):" & @CRLF & _
"13 length, no space, not start with 4 0123123412341" & @CRLF & _
"13 length, dashes, not start with 4 0123-1234-1234-1" & @CRLF & _
"13 length, spaces, not start with 4 0123 1234 1234 1" & @CRLF & _
"" & @CRLF & _
"16 length, no space, not start with 4 0221123412341234" & @CRLF & _
"16 length, dashes, not start with 4 0221-1234-1234-1234" & @CRLF & _
"16 length, spaces, not start with 4 0221 1234 1234 1234" & @CRLF & _
"" & @CRLF & _
"19 length, no space, not start with 4 0241123412341234123" & @CRLF & _
"19 length, dashes, not start with 4 0241-1234-1234-1234-123" & @CRLF & _
"19 length, spaces, not start with 4 0241 1234 1234 1234-123" & @CRLF & _
"" & @CRLF & _
"13 length, no space, start with 4, embedded Credit Card Number4123123412341" & @CRLF & _
"13 length, dashes, start with 4, malformed 412-31234-12341" & @CRLF & _
"13 length num matching pattern but embedded User ID: 0000004123123412341000000 " & @CRLF & _
"16 length, no space, start with 4, embedded Credit Card Number4123123412341234" & @CRLF & _
"16 length, dashes, start with 4, malformed 412-312-34123-41234" & @CRLF & _
"16 length num matching pattern but embedded User ID: 0000004123123412341234000000" & @CRLF & _
"" & @CRLF & _
"19 length, no space, start with 4, embedded Credit Card Number4123123412341234123" & @CRLF & _
"19 length, dashes, start with 4, malformed 412-312341-234123-4123" & @CRLF & _
"19 length num matching pattern but embedded User ID: 0000004123123412341234123000000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")