import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b";
final String string = "Visa\n\n"
+ "Requirements: Visa numbers start with the number 4 and have either 13, 16, or 19 digits (new cards).\n\n"
+ "Pattern Parts:\n"
+ "Starts with number 4 and 13 length:\n"
+ "1) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b\n\n"
+ "Starts with number 4 and 16 length:\n"
+ "2) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b\n\n"
+ "Starts with number 4 and 19 length:\n"
+ "3) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b\n\n"
+ "Combining 1-3 to form one pattern:\n"
+ "\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b\n\n\n"
+ "Test Cases:\n"
+ "Positive (should fire):\n"
+ "13 length, no space, start with 4 Here is the cc: 4123123412341 Thanks.\n"
+ "13 length, dashes, start with 4 4123-1234-1234-1\n"
+ "13 length, spaces, start with 4 4123 1234 1234 1\n\n"
+ "16 length, no space, start with 4 4221123412341234\n"
+ "16 length, dashes, start with 4 4221-1234-1234-1234\n"
+ "16 length, spaces, start with 4 4221 1234 1234 1234\n\n"
+ "19 length, no space, start with 4 4241123412341234123\n"
+ "19 length, dashes, start with 4 4241-1234-1234-1234-123\n"
+ "19 length, spaces, start with 4 4241 1234 1234 1234-123\n\n"
+ "Embedded in sentence with space:\n"
+ "13 length, no space, start with 4 Here is the cc: 4123123412341\n"
+ "13 length, dashes, start with 4 Here is the cc: 4123-1234-1234-1\n"
+ "13 length, spaces, start with 4 Here is the cc: 4123 1234 1234 1\n\n"
+ "16 length, no space, start with 4 Here is the cc: 4221123412341234\n"
+ "16 length, dashes, start with 4 Here is the cc: 4221-1234-1234-1234\n"
+ "16 length, spaces, start with 4 Here is the cc: 4221 1234 1234 1234\n\n"
+ "19 length, no space, start with 4 Here is the cc: 4241123412341234123\n"
+ "19 length, dashes, start with 4 Here is the cc: 4241-1234-1234-1234-123\n"
+ "19 length, spaces, start with 4 Here is the cc: 4241 1234 1234 1234-123\n\n"
+ "13 length, no space, start with 4 Here is the card#:4123123412341\n"
+ "13 length, dashes, start with 4 Here is the card#:4123-1234-1234-1\n"
+ "13 length, spaces, start with 4 Here is the card#:4123 1234 1234 1\n\n"
+ "16 length, no space, start with 4 Here is the card#:4221123412341234\n"
+ "16 length, dashes, start with 4 Here is the card#:4221-1234-1234-1234\n"
+ "16 length, spaces, start with 4 Here is the card#:4221 1234 1234 1234\n\n"
+ "19 length, no space, start with 4 Here is the card#:4241123412341234123\n"
+ "19 length, dashes, start with 4 Here is the card#:4241-1234-1234-1234-123\n"
+ "19 length, spaces, start with 4 Here is the card#:4241 1234 1234 1234-123\n\n"
+ "Negative (should not fire):\n"
+ "13 length, no space, not start with 4 0123123412341\n"
+ "13 length, dashes, not start with 4 0123-1234-1234-1\n"
+ "13 length, spaces, not start with 4 0123 1234 1234 1\n\n"
+ "16 length, no space, not start with 4 0221123412341234\n"
+ "16 length, dashes, not start with 4 0221-1234-1234-1234\n"
+ "16 length, spaces, not start with 4 0221 1234 1234 1234\n\n"
+ "19 length, no space, not start with 4 0241123412341234123\n"
+ "19 length, dashes, not start with 4 0241-1234-1234-1234-123\n"
+ "19 length, spaces, not start with 4 0241 1234 1234 1234-123\n\n"
+ "13 length, no space, start with 4, embedded Credit Card Number4123123412341\n"
+ "13 length, dashes, start with 4, malformed 412-31234-12341\n"
+ "13 length num matching pattern but embedded User ID: 0000004123123412341000000 \n"
+ "16 length, no space, start with 4, embedded Credit Card Number4123123412341234\n"
+ "16 length, dashes, start with 4, malformed 412-312-34123-41234\n"
+ "16 length num matching pattern but embedded User ID: 0000004123123412341234000000\n\n"
+ "19 length, no space, start with 4, embedded Credit Card Number4123123412341234123\n"
+ "19 length, dashes, start with 4, malformed 412-312341-234123-4123\n"
+ "19 length num matching pattern but embedded User ID: 0000004123123412341234123000000\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}