use strict;
my $str = 'Visa
Requirements: Visa numbers start with the number 4 and have either 13, 16, or 19 digits (new cards).
Pattern Parts:
Starts with number 4 and 13 length:
1) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b
Starts with number 4 and 16 length:
2) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b
Starts with number 4 and 19 length:
3) \\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b
Combining 1-3 to form one pattern:
\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\\b|\\b4[0-9][0-9]{11}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\\b|\\b4[0-9][0-9]{14}\\b|\\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\\b|\\b4[0-9][0-9]{17}\\b
Test Cases:
Positive (should fire):
13 length, no space, start with 4 Here is the cc: 4123123412341 Thanks.
13 length, dashes, start with 4 4123-1234-1234-1
13 length, spaces, start with 4 4123 1234 1234 1
16 length, no space, start with 4 4221123412341234
16 length, dashes, start with 4 4221-1234-1234-1234
16 length, spaces, start with 4 4221 1234 1234 1234
19 length, no space, start with 4 4241123412341234123
19 length, dashes, start with 4 4241-1234-1234-1234-123
19 length, spaces, start with 4 4241 1234 1234 1234-123
Embedded in sentence with space:
13 length, no space, start with 4 Here is the cc: 4123123412341
13 length, dashes, start with 4 Here is the cc: 4123-1234-1234-1
13 length, spaces, start with 4 Here is the cc: 4123 1234 1234 1
16 length, no space, start with 4 Here is the cc: 4221123412341234
16 length, dashes, start with 4 Here is the cc: 4221-1234-1234-1234
16 length, spaces, start with 4 Here is the cc: 4221 1234 1234 1234
19 length, no space, start with 4 Here is the cc: 4241123412341234123
19 length, dashes, start with 4 Here is the cc: 4241-1234-1234-1234-123
19 length, spaces, start with 4 Here is the cc: 4241 1234 1234 1234-123
13 length, no space, start with 4 Here is the card#:4123123412341
13 length, dashes, start with 4 Here is the card#:4123-1234-1234-1
13 length, spaces, start with 4 Here is the card#:4123 1234 1234 1
16 length, no space, start with 4 Here is the card#:4221123412341234
16 length, dashes, start with 4 Here is the card#:4221-1234-1234-1234
16 length, spaces, start with 4 Here is the card#:4221 1234 1234 1234
19 length, no space, start with 4 Here is the card#:4241123412341234123
19 length, dashes, start with 4 Here is the card#:4241-1234-1234-1234-123
19 length, spaces, start with 4 Here is the card#:4241 1234 1234 1234-123
Negative (should not fire):
13 length, no space, not start with 4 0123123412341
13 length, dashes, not start with 4 0123-1234-1234-1
13 length, spaces, not start with 4 0123 1234 1234 1
16 length, no space, not start with 4 0221123412341234
16 length, dashes, not start with 4 0221-1234-1234-1234
16 length, spaces, not start with 4 0221 1234 1234 1234
19 length, no space, not start with 4 0241123412341234123
19 length, dashes, not start with 4 0241-1234-1234-1234-123
19 length, spaces, not start with 4 0241 1234 1234 1234-123
13 length, no space, start with 4, embedded Credit Card Number4123123412341
13 length, dashes, start with 4, malformed 412-31234-12341
13 length num matching pattern but embedded User ID: 0000004123123412341000000
16 length, no space, start with 4, embedded Credit Card Number4123123412341234
16 length, dashes, start with 4, malformed 412-312-34123-41234
16 length num matching pattern but embedded User ID: 0000004123123412341234000000
19 length, no space, start with 4, embedded Credit Card Number4123123412341234123
19 length, dashes, start with 4, malformed 412-312341-234123-4123
19 length num matching pattern but embedded User ID: 0000004123123412341234123000000
';
my $regex = qr/\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}[0-9]\b|\b4[0-9][0-9]{11}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){2}(?:[0-9]{4})?$\b|\b4[0-9][0-9]{14}\b|\b(4[0-9]{3}[ -])([0-9]{4}[ -]){3}(?:[0-9]{3})?$\b|\b4[0-9][0-9]{17}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}