using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9\u00B5-\u00FF]";
string input = @"abcdefghijklmnopqrstuvwxyz asvùàçéèçǵ 123456789 !@#$%^&*)_+}{|""?><
QWERTYUIOPASDFGHJKLZXCVBNM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}