using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"''+(?!['f])";
string input = @"don't '''theater''' but not'''d and not do'''f";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}