re = /''+(?!['f])/
str = 'don\'t \'\'\'theater\'\'\' but not\'\'\'d and not do\'\'\'f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end