$re = '/\'\'+(?![\'f])/';
$str = 'don\'t \'\'\'theater\'\'\' but not\'\'\'d and not do\'\'\'f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);