$re = '/[a-zA-Z]+\s+:\s+[a-zA-Z]+\s+:\s+\d+\s+:\s+\d+/m';
$str = 'test : test : 0 : 0
: test: 0 : 0
0 : test : 0 : test
test test : 0 : 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);