import re
regex = re.compile(r"[a-zA-Z]+\s+:\s+[a-zA-Z]+\s+:\s+\d+\s+:\s+\d+", flags=re.MULTILINE)
test_str = ("test : test : 0 : 0\n"
": test: 0 : 0\n"
"0 : test : 0 : test\n"
"test test : 0 : 0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")