re = /[a-zA-Z]+\s+:\s+[a-zA-Z]+\s+:\s+\d+\s+:\s+\d+/m
str = 'test : test : 0 : 0
: test: 0 : 0
0 : test : 0 : test
test test : 0 : 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end