#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^acl\s(?P<acl_name>[^.\s]+)\s+\w+\s(?P<dest_domain>[-a-zA-Z0-9@:%._\+~#=]{1,256})"
Local $sString = "# log_mime_hdrs on" & @CRLF & _
"" & @CRLF & _
"# Turn off caching" & @CRLF & _
"cache deny all" & @CRLF & _
"" & @CRLF & _
"# Disable ICMP pinger" & @CRLF & _
"pinger_enable off" & @CRLF & _
"" & @CRLF & _
"# Consult local hosts file" & @CRLF & _
"# hosts_file /etc/hosts" & @CRLF & _
"" & @CRLF & _
"# Set squid pidfile location" & @CRLF & _
"pid_filename /var/run/squid/squid.pid" & @CRLF & _
"" & @CRLF & _
"# Set squid access logging location and use more human-readable format" & @CRLF & _
"access_log stdio:/var/log/squid/access_combined.log logformat=combined" & @CRLF & _
"access_log daemon:/var/log/squid/access_default.log logformat=squid" & @CRLF & _
"" & @CRLF & _
"# Set cache logging location" & @CRLF & _
"cache_log /var/log/squid/cache.log" & @CRLF & _
"" & @CRLF & _
"# Do not allow caching me" & @CRLF & _
"F5 BIG-IQ" & @CRLF & _
"# Mgmt Self-Outside" & @CRLF & _
"acl $masked_host$ src 20.20.30.4/32 160.11.44.56/32 # F5 BIG-IQ" & @CRLF & _
"acl $masked_host$ src 20.20.30.132/32 160.11.44.184/32 # F5 BIG-IQ" & @CRLF & _
"" & @CRLF & _
"# External F5" & @CRLF & _
"# Mgmt Self-Outside Floating-Outside Self-Inside Floating-Inside" & @CRLF & _
"acl $masked_host$ src 160.11.42.8/32 192.160.223.74/32 160.11.42.142/32 # External F5 BIG-IP" & @CRLF & _
"acl $masked_host$ src 160.11.43.8/32 192.160.224.74/32 160.11.43.142/32 # External F5 BIG-IP" & @CRLF & _
"" & @CRLF & _
"# External F5" & @CRLF & _
"# Mgmt Self-Outside Floating-Outside Self-Inside Floating-Inside" & @CRLF & _
"acl $masked_host$ src 160.11.42.4/32 192.160.223.4/32 192.160.223.46/32 160.11.42.132/32 160.11.42.140/32 # External F5 BIG-IP" & @CRLF & _
"acl $masked_host$ src 160.11.42.6/32 192.160.223.5/32 192.160.223.46/32 160.11.42.138/32 160.11.42.140/32 # External F5 BIG-IP" & @CRLF & _
"acl $masked_host$ src 160.11.43.4/32 192.160.224.4/32 192.160.224.46/32 160.11.43.132/32 160.11.43.140/32 # External F5 BIG-IP" & @CRLF & _
"acl $masked_host$ src 160.11.43.6/32 192.160.224.5/32 192.160.224.46/32 160.11.43.138/32 160.11.43.140/32 # External F5 BIG-IP" & @CRLF & _
"" & @CRLF & _
"acl github_domains dstdomain .github.com" & @CRLF & _
"acl clamav_domains dstdomain .clamav.net" & @CRLF & _
"acl mozilla_org_domains dstdomain .mozilla.org" & @CRLF & _
"acl mozilla_net_domains dstdomain .mozilla.net" & @CRLF & _
"acl mozilla_com_domains dstdomain .mozilla.com" & @CRLF & _
"acl google_domains dstdomain .google.com" & @CRLF & _
"acl google_apis_domains dstdomain .googleapis.com" & @CRLF & _
"acl powershell_domains dstdomain .digicert.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")