import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^acl\\s(?P<acl_name>[^.\\s]+)\\s+\\w+\\s(?P<dest_domain>[-a-zA-Z0-9@:%._\\+~#=]{1,256})";
final String string = "# log_mime_hdrs on\n\n"
+ "# Turn off caching\n"
+ "cache deny all\n\n"
+ "# Disable ICMP pinger\n"
+ "pinger_enable off\n\n"
+ "# Consult local hosts file\n"
+ "# hosts_file /etc/hosts\n\n"
+ "# Set squid pidfile location\n"
+ "pid_filename /var/run/squid/squid.pid\n\n"
+ "# Set squid access logging location and use more human-readable format\n"
+ "access_log stdio:/var/log/squid/access_combined.log logformat=combined\n"
+ "access_log daemon:/var/log/squid/access_default.log logformat=squid\n\n"
+ "# Set cache logging location\n"
+ "cache_log /var/log/squid/cache.log\n\n"
+ "# Do not allow caching me\n"
+ "F5 BIG-IQ\n"
+ "# Mgmt Self-Outside\n"
+ "acl $masked_host$ src 20.20.30.4/32 160.11.44.56/32 # F5 BIG-IQ\n"
+ "acl $masked_host$ src 20.20.30.132/32 160.11.44.184/32 # F5 BIG-IQ\n\n"
+ "# External F5\n"
+ "# Mgmt Self-Outside Floating-Outside Self-Inside Floating-Inside\n"
+ "acl $masked_host$ src 160.11.42.8/32 192.160.223.74/32 160.11.42.142/32 # External F5 BIG-IP\n"
+ "acl $masked_host$ src 160.11.43.8/32 192.160.224.74/32 160.11.43.142/32 # External F5 BIG-IP\n\n"
+ "# External F5\n"
+ "# Mgmt Self-Outside Floating-Outside Self-Inside Floating-Inside\n"
+ "acl $masked_host$ src 160.11.42.4/32 192.160.223.4/32 192.160.223.46/32 160.11.42.132/32 160.11.42.140/32 # External F5 BIG-IP\n"
+ "acl $masked_host$ src 160.11.42.6/32 192.160.223.5/32 192.160.223.46/32 160.11.42.138/32 160.11.42.140/32 # External F5 BIG-IP\n"
+ "acl $masked_host$ src 160.11.43.4/32 192.160.224.4/32 192.160.224.46/32 160.11.43.132/32 160.11.43.140/32 # External F5 BIG-IP\n"
+ "acl $masked_host$ src 160.11.43.6/32 192.160.224.5/32 192.160.224.46/32 160.11.43.138/32 160.11.43.140/32 # External F5 BIG-IP\n\n"
+ "acl github_domains dstdomain .github.com\n"
+ "acl clamav_domains dstdomain .clamav.net\n"
+ "acl mozilla_org_domains dstdomain .mozilla.org\n"
+ "acl mozilla_net_domains dstdomain .mozilla.net\n"
+ "acl mozilla_com_domains dstdomain .mozilla.com\n"
+ "acl google_domains dstdomain .google.com\n"
+ "acl google_apis_domains dstdomain .googleapis.com\n"
+ "acl powershell_domains dstdomain .digicert.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}