const regex = /^acl\s(?P<acl_name>[^.\s]+)\s+\w+\s(?P<dest_domain>[-a-zA-Z0-9@:%._\+~#=]{1,256})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^acl\\s(?P<acl_name>[^.\\s]+)\\s+\\w+\\s(?P<dest_domain>[-a-zA-Z0-9@:%._\\+~#=]{1,256})', 'gm')
const str = `# log_mime_hdrs on
# Turn off caching
cache deny all
# Disable ICMP pinger
pinger_enable off
# Consult local hosts file
# hosts_file /etc/hosts
# Set squid pidfile location
pid_filename /var/run/squid/squid.pid
# Set squid access logging location and use more human-readable format
access_log stdio:/var/log/squid/access_combined.log logformat=combined
access_log daemon:/var/log/squid/access_default.log logformat=squid
# Set cache logging location
cache_log /var/log/squid/cache.log
# Do not allow caching me
F5 BIG-IQ
# Mgmt Self-Outside
acl \$masked_host\$ src 20.20.30.4/32 160.11.44.56/32 # F5 BIG-IQ
acl \$masked_host\$ src 20.20.30.132/32 160.11.44.184/32 # F5 BIG-IQ
# External F5
# Mgmt Self-Outside Floating-Outside Self-Inside Floating-Inside
acl \$masked_host\$ src 160.11.42.8/32 192.160.223.74/32 160.11.42.142/32 # External F5 BIG-IP
acl \$masked_host\$ src 160.11.43.8/32 192.160.224.74/32 160.11.43.142/32 # External F5 BIG-IP
# External F5
# Mgmt Self-Outside Floating-Outside Self-Inside Floating-Inside
acl \$masked_host\$ src 160.11.42.4/32 192.160.223.4/32 192.160.223.46/32 160.11.42.132/32 160.11.42.140/32 # External F5 BIG-IP
acl \$masked_host\$ src 160.11.42.6/32 192.160.223.5/32 192.160.223.46/32 160.11.42.138/32 160.11.42.140/32 # External F5 BIG-IP
acl \$masked_host\$ src 160.11.43.4/32 192.160.224.4/32 192.160.224.46/32 160.11.43.132/32 160.11.43.140/32 # External F5 BIG-IP
acl \$masked_host\$ src 160.11.43.6/32 192.160.224.5/32 192.160.224.46/32 160.11.43.138/32 160.11.43.140/32 # External F5 BIG-IP
acl github_domains dstdomain .github.com
acl clamav_domains dstdomain .clamav.net
acl mozilla_org_domains dstdomain .mozilla.org
acl mozilla_net_domains dstdomain .mozilla.net
acl mozilla_com_domains dstdomain .mozilla.com
acl google_domains dstdomain .google.com
acl google_apis_domains dstdomain .googleapis.com
acl powershell_domains dstdomain .digicert.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}