package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\w{1,2})\b`)
var str = `I have a string field containing many words and I would like to remove all 1 and 2 character words from it`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}