$re = '/\b(\w{1,2})\b/m';
$str = 'I have a string field containing many words and I would like to remove all 1 and 2 character words from it';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);