re = /\b(\w{1,2})\b/m
str = 'I have a string field containing many words and I would like to remove all 1 and 2 character words from it'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end