using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[7-9]\b|\b[1-9]\d+\b";
string input = @"1
5
6
7
10
22
99
120
1254221
012
001";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}