const regex = /\b[7-9]\b|\b[1-9]\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[7-9]\\b|\\b[1-9]\\d+\\b', 'g')
const str = `1
5
6
7
10
22
99
120
1254221
012
001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}