$re = '/\b[7-9]\b|\b[1-9]\d+\b/';
$str = '1
5
6
7
10
22
99
120
1254221
012
001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);