#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\s(\d\d:\d\d)"
Local $sString = "Connection 1" & @CRLF & _
"Server message: 2022-10-15 23:56:07:028" & @CRLF & _
"Message number: 0, Severity 10, State 1, Line 42" & @CRLF & _
"Procedure 'psp_dba_maint_4'" & @CRLF & _
"Message String: Successfulyl finished running psp_dba_maint_4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")