package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s(\d\d:\d\d)`)
var str = `Connection 1
Server message: 2022-10-15 23:56:07:028
Message number: 0, Severity 10, State 1, Line 42
Procedure 'psp_dba_maint_4'
Message String: Successfulyl finished running psp_dba_maint_4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}