re = /\s(\d\d:\d\d)/i
str = 'Connection 1
Server message: 2022-10-15 23:56:07:028
Message number: 0, Severity 10, State 1, Line 42
Procedure \'psp_dba_maint_4\'
Message String: Successfulyl finished running psp_dba_maint_4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end