using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s*(one|two|three)\s*$|(^\s*(one|two|three)([ ,;]+(one|two|three))+\s*$))";
string input = @"one
two one
one three one
four
one four
one two three four";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}