$re = '/(^\s*(one|two|three)\s*$|(^\s*(one|two|three)([ ,;]+(one|two|three))+\s*$))/m';
$str = 'one
two one
one three one
four
one four
one two three four';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);