re = /(^\s*(one|two|three)\s*$|(^\s*(one|two|three)([ ,;]+(one|two|three))+\s*$))/m
str = 'one
two one
one three one
four
one four
one two three four'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end