#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^a*(?:b+(?:a{2,})*)*bab(?:(?:a(?:a+b*)*)*|b+a*)$"
Local $sString = "bab" & @CRLF & _
"aaa" & @CRLF & _
"aba" & @CRLF & _
"aaaabab" & @CRLF & _
"bbbbabbbbb" & @CRLF & _
"bbbababaaabab" & @CRLF & _
"babbab" & @CRLF & _
"babab" & @CRLF & _
"baaaa" & @CRLF & _
"abbaaaaabbaba"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")