$re = '/^a*(?:b+(?:a{2,})*)*bab(?:(?:a(?:a+b*)*)*|b+a*)$/m';
$str = 'bab
aaa
aba
aaaabab
bbbbabbbbb
bbbababaaabab
babbab
babab
baaaa
abbaaaaabbaba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);