import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^a*(?:b+(?:a{2,})*)*bab(?:(?:a(?:a+b*)*)*|b+a*)$";
final String string = "bab\n"
+ "aaa\n"
+ "aba\n"
+ "aaaabab\n"
+ "bbbbabbbbb\n"
+ "bbbababaaabab\n"
+ "babbab\n"
+ "babab\n"
+ "baaaa\n"
+ "abbaaaaabbaba";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}