import re
regex = re.compile(r"([^,\s=]+)\s*=\s*(?|'([^']*)'|(\S+))", flags=re.MULTILINE)
test_str = "col1 = 'Test String' , col2= 'Next Test String',col3='Last Text String', col4=37"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")