// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^,\s=]+)\s*=\s*(?|'([^']*)'|(\S+))").unwrap();
let string = "col1 = 'Test String' , col2= 'Next Test String',col3='Last Text String', col4=37";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}