using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bX\.(?:[3-9]|1[0-3])(?!\d)";
string input = @"X.2
:X.3word
%X.4w
X.5w
)X.6w
'X.7w
""X.8w
.X.9w
,X.10w
/X.11w
=X.12w
X.13w
X.14";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}