use strict;
my $str = 'X.2
:X.3word
%X.4w
X.5w
)X.6w
\'X.7w
"X.8w
.X.9w
,X.10w
/X.11w
=X.12w
X.13w
X.14';
my $regex = qr/\bX\.(?:[3-9]|1[0-3])(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}