import re
regex = re.compile(r"\bX\.(?:[3-9]|1[0-3])(?!\d)", flags=re.MULTILINE)
test_str = ("X.2\n"
":X.3word\n"
"%X.4w\n"
" X.5w\n"
")X.6w\n"
"'X.7w\n"
"\"X.8w\n"
".X.9w\n"
",X.10w\n"
"/X.11w\n"
"=X.12w\n"
"X.13w\n"
"X.14")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")