const regex = /(?<=Client ID: )(.+)(?=\\r\\nClient Name)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Client ID: )(.+)(?=\\\\r\\\\nClient Name)', 'gm')
const str = `Client ID: TD88219\\r\\nClient Name: Caroll Eisenmann\\r\\nClient Country: Romania`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}