re = /(?<=Client ID: )(.+)(?=\\r\\nClient Name)/m
str = 'Client ID: TD88219\\r\\nClient Name: Caroll Eisenmann\\r\\nClient Country: Romania'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end