$re = '/(?<=Client ID: )(.+)(?=\\\\r\\\\nClient Name)/m';
$str = 'Client ID: TD88219\\r\\nClient Name: Caroll Eisenmann\\r\\nClient Country: Romania';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);