import re
regex = re.compile(r"\brs\W*?(\d{1,7}(?:,\d+)*)\b(?:\s*?(?:-|to)\s*?(?:\brs\b\W*?)?(\d{1,7}(?:,\d+)*)\b)?", flags=re.IGNORECASE)
test_str = ("The price was Rs.1000\n"
"The price was Rs 1000\n"
"The price was Rs.1000 - 5000\n"
"The price was Rs.1000 - Rs.5000\n"
"The price was Rs.50,000\n"
"The price was Rs 1,25,000 - Rs 2,45,000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")