const regex = /(?:.*?|\G)(\d\d\.\d\d\.(?:\d{4})?)|.*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*?|\\G)(\\d\\d\\.\\d\\d\\.(?:\\d{4})?)|.*', 'gs')
const str = `BEGIN:VNOTE
VERSION:1.1
BODY;ENCODING=QUOTED-PRINTABLE;CHARSET=UTF-8:18.07.=0A14.08.=0A15.09.=0A15.10.=
=0A13.11.=0A13.12.=0A12.01.=0A03.02. Grippe=0A06.03.=0A04.04.2015=0A0=
5.05.2015=0A03.06.2015=0A03.07.2015=0A02.08.2015=0A30.08.2015=0A28.09=
17.11.2017=0A
DCREATED:20171118T095601
X-IRMC-LUID:150
END:VNOTE`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);