# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(-?(?:[1-9][0-9]*)?[0-9]{4})-(1[0-2]|0[1-9])-(3[01]|0[1-9]|[12][0-9])T(2[0-3]|[01][0-9]):([0-5][0-9]):([0-5][0-9])(\\.[0-9]+)?(Z)?/$1-$2-$3 $4:$5/gm;t' <<< "1922-08-22T05:00:00Z"