import re
regex = re.compile(r"(-?(?:[1-9][0-9]*)?[0-9]{4})-(1[0-2]|0[1-9])-(3[01]|0[1-9]|[12][0-9])T(2[0-3]|[01][0-9]):([0-5][0-9]):([0-5][0-9])(\\.[0-9]+)?(Z)?", flags=re.MULTILINE)
test_str = "1922-08-22T05:00:00Z"
subst = "$1-$2-$3 $4:$5"
result = regex.sub(subst, test_str)
if result:
print(result)