package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Zåçêëèïîìæôöòûùÿáíóúñ]+(?:[-' ][a-zA-Zåçêëèïîìæôöòûùÿáíóúñ]+)*$`)
var str = `Le'brahm
Ben-John
Ben-John Smith's
Le' brahm
Ben -John
Ben- John`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}