re = /^[a-zA-Zåçêëèïîìæôöòûùÿáíóúñ]+(?:[-' ][a-zA-Zåçêëèïîìæôöòûùÿáíóúñ]+)*$/m
str = 'Le\'brahm
Ben-John
Ben-John Smith\'s
Le\' brahm
Ben -John
Ben- John'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end