$re = '/^[a-zA-Zåçêëèïîìæôöòûùÿáíóúñ]+(?:[-\' ][a-zA-Zåçêëèïîìæôöòûùÿáíóúñ]+)*$/m';
$str = 'Le\'brahm
Ben-John
Ben-John Smith\'s
Le\' brahm
Ben -John
Ben- John';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);