package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b5\d{6}(?:\D|$)`)
var str = `34324, 5604020, 45309, 45, 55, 5102903
5604020`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}