$re = '/\b5\d{6}(?:\D|$)/m';
$str = '34324, 5604020, 45309, 45, 55, 5102903
5604020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);