const regex = /\b5\d{6}(?:\D|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b5\\d{6}(?:\\D|$)', 'gm')
const str = `34324, 5604020, 45309, 45, 55, 5102903
5604020`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}